The following article may require assistance from your IT department/provider. We recommend forwarding this article to them to apply the solution provided.
Description
When starting Micromine Origin & Beyond. You may run into the following error:
The License cannot be checked out . Unable to find the license feature. (1:9)
Solution
Licence server
- Remote onto the network licence server
- Navigate to C:\Program Files\Micromine Network License Server\ and verify if nls-util.exe exists in this location. If it does not, you can download a copy of the Network Licence Server Management Utility (NLS-UTIL) here and copy the file to the directory.
- Launch Run (Windows Key + R)
- Enter cmd followed by OK
- Change your working directory to the folder of your Network Licence Server, where you have moved the NLS-UTIL. For example:
cd C:\Program Files\Micromine Network License Server
- Use the following command to show the current licence features installed. This will show you the features you can return. Replace the IP to your existing NLS.
nls-util.exe -server 127.0.0.1 -command list-licence-features
You may see that there are no licenses activated on the licence. Either the license has been deleted, de-activated or moved to another server.
- Use the following command to activate your license feature on the server.
nls-util.exe -server 127.0.0.1 -command activate-licence -activation-code ActivationCode
If you do not have your activation code, please contact Micromine support.
Client Computer
- Relaunch Micromine Origin & Beyond to determine if the issue has been resolved.
- If the issue is still occurring on your own and/or other users using the network licence, follow our article on How to connect and use a network licence. This article will help you create a new licence configuration.
Cause
The license feature no longer exists on the server. It has either been deleted, moved or deactivated.
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