The following article may require assistance from your IT department/provider. We recommend forwarding this article to them to apply the solution provided.
Description
You may get the following error when trying to Activate / Update your licence.
Solution
On your computer
- On your computer, ensure that you are connected to your organisations network.
- Download and run the Micromine Licensing Diagnostics Tool here.
- Add the Licence server to the Text box in the top right in the following format.
6200@IPAddress or 6200@Hostname - Click Test Network Licence Server Connection and review the results.
On the server
- On the server, you will need to create inbound rules to allow ports 6200 TCP/UDP and 6000 TCP
You can read more about how to do this from Microsoft here.
- You will need to replicate these rules on your network firewall (if applicable).
- Going back to the client computer, attempt your activation again.
Cause
- Ports 6200 TCP/UDP and 6000 TCP are being blocked
- SSL inspection may be enabled. We recommend bypassing traffic that is inspected.
- Licence server is not communicating with the Micromine Licensing Service (MLS)
- Client device is not able to reach the Network Licence Server (NLS)
- The Micromine Network Licence Server service is not running
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